<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns#" lang="en">
  <head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="author" content="Toast, Inc.">
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=5.0, user-scalable=yes" />
    <meta data-rh="true" name="og:url" content="https://www.toasttab.com/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128"/><meta data-rh="true" name="og:title" content="Barker&#x27;s Ice Cream &amp; More | Toast"/>

    <title data-rh="true">Barker&#x27;s Ice Cream &amp; More | Toast</title>

    <link data-rh="true" rel="canonical" href="https://www.toasttab.com/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128"/><link data-rh="true" rel="icon" id="favicon" href="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/favicon-32x32.png"/>

    <style data-rh="true" type="text/css">
  
  

  :root {
    /* Try to prevent CSS conflicts in Toast Admin by prefixing variables with 'tsw-' (Toast Sites Web) */
    --tsw-background-color: #FFFFFF;
    --tsw-background-color-med: #FFFFFF40;
    --tsw-primary-color: #FF4C00;
    --tsw-primary-hover-color: #eb3800;
    --tsw-primary-hover-color-light: #FF4C0020;
    --tsw-primary-hover-color-med: #FF4C0040;
    --tsw-primary-text-color: #252525;
    --tsw-secondary-text-color: #FFFFFF;
    --tsw-link-color: #2B4FB9;
    --tsw-font-family: "Effra";
    --tsw-header-font-family: "Effra";
  }
  </style>

    <meta name="msapplication-TileColor" content="#b91d47">
    <meta name="theme-color" content="#ffffff">

    <link rel="stylesheet" href="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/app/public_1669921619.min.css">

    <!-- PURE CSS -->
    <link rel="stylesheet" href="https://unpkg.com/purecss@1.0.0/build/grids-min.css" />
    <link rel="stylesheet" href="https://unpkg.com/purecss@1.0.0/build/grids-responsive-min.css" />


      <!-- Mixpanel -->
      <script type="text/javascript">
        (function(f,b){if(!b.__SV){var e,g,i,h;window.mixpanel=b;b._i=[];b.init=function(e,f,c){function g(a,d){var b=d.split(".");2==b.length&&(a=a[b[0]],d=b[1]);a[d]=function(){a.push([d].concat(Array.prototype.slice.call(arguments,0)))}}var a=b;"undefined"!==typeof c?a=b[c]=[]:c="mixpanel";a.people=a.people||[];a.toString=function(a){var d="mixpanel";"mixpanel"!==c&&(d+="."+c);a||(d+=" (stub)");return d};a.people.toString=function(){return a.toString(1)+".people (stub)"};i="disable time_event track track_pageview track_links track_forms track_with_groups add_group set_group remove_group register register_once alias unregister identify name_tag set_config reset opt_in_tracking opt_out_tracking has_opted_in_tracking has_opted_out_tracking clear_opt_in_out_tracking start_batch_senders people.set people.set_once people.unset people.increment people.append people.union people.track_charge people.clear_charges people.delete_user people.remove".split(" ");
        for(h=0;h<i.length;h++)g(a,i[h]);var j="set set_once union unset remove delete".split(" ");a.get_group=function(){function b(c){d[c]=function(){call2_args=arguments;call2=[c].concat(Array.prototype.slice.call(call2_args,0));a.push([e,call2])}}for(var d={},e=["get_group"].concat(Array.prototype.slice.call(arguments,0)),c=0;c<j.length;c++)b(j[c]);return d};b._i.push([e,f,c])};b.__SV=1.2;e=f.createElement("script");e.type="text/javascript";e.async=!0;e.src="undefined"!==typeof MIXPANEL_CUSTOM_LIB_URL?
        MIXPANEL_CUSTOM_LIB_URL:"file:"===f.location.protocol&&"//cdn.mxpnl.com/libs/mixpanel-2-latest.min.js".match(/^\/\//)?"https://cdn.mxpnl.com/libs/mixpanel-2-latest.min.js":"//cdn.mxpnl.com/libs/mixpanel-2-latest.min.js";g=f.getElementsByTagName("script")[0];g.parentNode.insertBefore(e,g)}})(document,window.mixpanel||[]);

        mixpanel.init('8c7673972d0c847bc7944640f0a9c311', { debug: false });
      </script>

      <!-- FullStory -->
      <script>
        window['_fs_debug'] = false;
        window['_fs_host'] = 'fullstory.com';
        window['_fs_script'] = 'edge.fullstory.com/s/fs.js';
        window['_fs_org'] = 'o-1AB338-na1';
        window['_fs_namespace'] = 'FS';
        (function(m,n,e,t,l,o,g,y){
            if (e in m) {if(m.console && m.console.log) { m.console.log('FullStory namespace conflict. Please set window["_fs_namespace"].');} return;}
            g=m[e]=function(a,b,s){g.q?g.q.push([a,b,s]):g._api(a,b,s);};g.q=[];
            o=n.createElement(t);o.async=1;o.crossOrigin='anonymous';o.src='https://'+_fs_script;
            y=n.getElementsByTagName(t)[0];y.parentNode.insertBefore(o,y);
            g.identify=function(i,v,s){g(l,{uid:i},s);if(v)g(l,v,s)};g.setUserVars=function(v,s){g(l,v,s)};g.event=function(i,v,s){g('event',{n:i,p:v},s)};
            g.anonymize=function(){g.identify(!!0)};
            g.shutdown=function(){g("rec",!1)};g.restart=function(){g("rec",!0)};
            g.log = function(a,b){g("log",[a,b])};
            g.consent=function(a){g("consent",!arguments.length||a)};
            g.identifyAccount=function(i,v){o='account';v=v||{};v.acctId=i;g(o,v)};
            g.clearUserCookie=function(){};
            g.setVars=function(n, p){g('setVars',[n,p]);};
            g._w={};y='XMLHttpRequest';g._w[y]=m[y];y='fetch';g._w[y]=m[y];
            if(m[y])m[y]=function(){return g._w[y].apply(this,arguments)};
            g._v="1.3.0";
        })(window,document,window['_fs_namespace'],'script','user');
      </script>

    <!-- Load the Redux State -->
    <script>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</script>
  </head>
  <body>
    <div id="content"><div class="tsw-app-wrapper"><div class="defaultTemplate"><nav class="globalNav stickyNav"><div class="navWrapper paddedSection"><div class="nav"><div class="left"><div class="logoTitle"><a href="https://www.toasttab.com/local" class=""><div class="logoWrapper"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/toast-logo-orange.svg" loading="lazy" alt="Restaurant logo" class="logo"/></div></a></div></div><div class="content"><div class="right hidden-lg-up"><button class="orderOptions hidden-sm-down"><div class="diningOptionBehavior"><span>Pickup<!-- --> <span class="link">ASAP</span></span></div><div class="addressFulfillment"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/map-pin-gray.svg" loading="lazy" alt="Map pin icon"/><span class="link">2100 7TH AVE</span></div></button><div class="cartTarget"><div class="popover"><div class="cartPopoverTarget"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/pickup.svg" loading="lazy" alt="Cart icon"/>0</div><div style="position:absolute;left:0;top:0" tabindex="0" class="popoverContent"><div class="arrow" style="position:absolute"><div></div></div><div class="cart"><div class="header"><h3>Your order</h3></div><div class="cartData"><div class="items"><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span></div></div><a class="" href="/local/order/barkers/javascript:;"><button class="checkoutButton" disabled=""><span>Checkout</span><span>$0.00</span></button></a></div></div></div></div></div></div><div class="right hidden-md-down"><button class="orderOptions"><div class="diningOptionBehavior"><span>Pickup<!-- --> <span class="link">ASAP</span></span></div><div class="addressFulfillment"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/map-pin-gray.svg" loading="lazy" alt="Map pin icon"/><span class="link">2100 7TH AVE</span></div></button><div class="popover"><div class="cartPopoverTarget"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/pickup.svg" loading="lazy" alt="Cart icon"/>0</div><div style="position:absolute;left:0;top:0" tabindex="0" class="popoverContent"><div class="arrow" style="position:absolute"><div></div></div><div class="cart"><div class="header"><h3>Your order</h3></div><div class="cartData"><div class="items"><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span><span aria-live="polite" aria-busy="true"><span class="react-loading-skeleton" style="margin-bottom:4px">‌</span><br/></span></div></div><a class="" href="/local/order/barkers/javascript:;"><button class="checkoutButton" disabled=""><span>Checkout</span><span>$0.00</span></button></a></div></div></div></div></div></div></nav><div class="paddedSection restaurantProfile"><div class="breadcrumbs"><ul><li class="crumb"><a href="https://www.toasttab.com/local" class="">Home</a></li><li class="crumb slash">/</li><li class="crumb"><a href="https://www.toasttab.com/local/marion-ia-restaurants" class="">Marion</a></li><li class="crumb slash">/</li><li class="crumb">Barker&#x27;s Ice Cream &amp; More</li></ul></div><div class="lg-reverse"><div class="rx-header-photo"><div class="image-container"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/restaurant_list_image_1632097026.jpg" loading="lazy" alt="Restaurant header image"/><a href="#rx-gallery" class="go-to-gallery-button"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/gallery-icon.svg" loading="lazy"/><span class="hidden-sm-down">View gallery</span></a></div></div><div class="rx-info"><div><div class="title-info"><h1 class="rx-page-section">Barker&#x27;s Ice Cream &amp; More</h1></div></div><div class="overview-container"><div class="rx-overview"><div class="stats"><span class="reviews"><div class="no-reviews-star"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="review star"/></div><p>No reviews yet</p></span></div><div class="address hidden-sm-down"><p class="line-1">2100 7TH AVE</p><p class="line-1"></p><p class="line-2">Marion, IA 52302</p></div><hr class="hidden-sm-down"/><div class="hidden-sm-down"><div class="commission-disclaimer"><div class="storefront-icon"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/storefront.svg" loading="lazy"/></div><p>Orders through Toast are commission free and go directly to this restaurant</p></div></div><hr/><div class="ctas"><a href="tel:3193771054" class="cta"><div class="icon"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/phone-default-icon-color.svg" loading="lazy" alt="phone icon" height="20"/></div><p>Call</p></a><a href="#rx-hours" class="cta"><div class="icon"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/clock-default-icon-color.svg" loading="lazy" alt="clock icon" height="20"/></div><p>Hours</p></a><a href="https://www.google.com/maps/search/?api=1&amp;query=2100%207TH%20AVE%2C%20Marion%2C%20IA%2052302" class="cta" target="_blank" rel="noreferrer noopener"><div class="icon"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/waypointSign-default-icon-color.svg" loading="lazy" alt="waypoint sign icon" height="20"/></div><p>Directions</p></a><a href="https://www.toasttab.com/barkers/giftcards" class="cta"><div class="icon"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/gift-default-icon-color.svg" loading="lazy" alt="gift icon" height="20"/></div><p>Gift Cards</p></a></div></div></div></div></div></div><div class="pageContent"><nav class="globalNav stickyNav secondaryNav withoutHero globalNavOpen"><div class="paddedContentWrapper"><div class="paddedContent withoutHero"><div style="overflow:visible;height:auto"><div class="mobileFulfillment hidden-md-up"><div class="diningOptionBehaviorInfo">You can only place scheduled delivery orders.</div><button class="orderOptions"><div class="diningOptionBehavior"><span>Pickup<!-- --> <span class="link">ASAP</span></span></div><div class="addressFulfillment"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/map-pin-gray.svg" loading="lazy" alt="Map pin icon"/><span class="link">2100 7TH AVE</span></div></button></div></div><div class="menuNav"><div class="sortPills"><button type="button" class="pill">Combos</button><button type="button" class="pill">Entrées</button><button type="button" class="pill">Ice Cream</button><button type="button" class="pill">Sides &amp; Soups</button><div class="hide"></div><button type="button" class="pill">Drinks</button></div></div></div></div></nav><div style="overflow:hidden;height:0px"><div class="orderAgain"><div class="paddedContentWrapper"><div class="paddedContent"><h3>Order Again</h3></div></div><div class="ordersWrapper"><div class="scrollWrapper"><div class="orders"></div></div></div><div class="paddedContentWrapper"><div class="paddedContent"><button type="button" class="button seeMore link">See more</button></div></div></div></div><div class="popularItemsSection paddedContentWrapper"><div class="paddedContent"><div class="headerWrapper"><h3 class="header">Popular Items</h3></div><div class="popularItemsList carousel"><div class="popularItemWrapper"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-faverite_3bcc6b27-becd-4de7-a1c8-009c2f4d6e07" style="pointer-events:auto" class="item left clickable"><div class="popularItem backgroundImage" style="background-image:url(https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/1/item-5740010887569871_1668634390.jpg)"><div class="itemName">Fave-Rite</div></div></a></div><div class="popularItemWrapper"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-white-cheddar-cheese-curds_5b2c2b07-3020-4267-af33-bf6fd4f1cc58" style="pointer-events:auto" class="item left clickable"><div class="popularItem backgroundImage" style="background-image:url(https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019891710850_1668634319.jpg)"><div class="itemName">White Cheddar Cheese Curds</div></div></a></div><div class="popularItemWrapper"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-faverite-combo_b9f37ebb-9bc8-4d5f-bf05-82dadb00c845" style="pointer-events:auto" class="item left clickable"><div class="popularItem"><div class="itemName">Fave-Rite Combo</div></div></a></div></div></div></div><div class="menuSectionWrapper"><div class="menuWrapper paddedContentWrapper"><div class="menu paddedContent"><div class="menuGroup"><section class="menuSection"><div class="headerWrapper"><h3 class="header">Combos</h3></div><div class="itemSection compact"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-faverite-combo_b9f37ebb-9bc8-4d5f-bf05-82dadb00c845" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Fave-Rite Combo</h3></div><div class="priceAvailability"><span class="price">$9.60</span></div><div class="itemContent"><p class="itemDescription">Our version of Iowa&#x27;s favorite loose meat sandwich. Includes fries AND one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-chili-faverite-combo_c096ebac-0beb-419d-a9e3-9e45860ae634" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Chili Fave-Rite Combo</h3></div><div class="priceAvailability"><span class="price">$10.80</span></div><div class="itemContent"><p class="itemDescription">Classic loose meat sandwich served open faced topped with our house made chili.
Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-hot-rite-combo_461219c0-65d9-46db-ab61-ad4f0e23a4b5" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Hot Rite Combo</h3></div><div class="priceAvailability"><span class="price">$12.20</span></div><div class="itemContent"><p class="itemDescription">Classic Fave-Rite sandwich served open faced with homemade mashed potatoes and gravy on top. Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-bbq-pork-sandwich-combo_9786c01f-320c-4349-a13e-199622f6acfe" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>BBQ Pork Sandwich Combo</h3></div><div class="priceAvailability"><span class="price">$10.20</span></div><div class="itemContent"><p class="itemDescription">Pulled pork in a smoky barbecue sauce. Includes fries AND one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-14lb-hot-dog-combo_06190136-2962-404d-bbec-90a49926ebf3" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>1/4lb Hot Dog Combo</h3></div><div class="priceAvailability"><span class="price">$9.00</span></div><div class="itemContent"><p class="itemDescription">1/4lb grilled hot dog. Try with our house made dill relish! Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-14lb-pretzel-dog-combo_46175df3-5d4f-4efe-b703-8be9ad0c3adf" style="pointer-events:auto" class="item left clickable outOfStock"><div class="itemInfo"><div class="itemHeader"><h3>1/4lb Pretzel Dog Combo</h3></div><div class="priceAvailability"><span class="price">$11.00</span><span>Out of stock</span></div><div class="itemContent"><p class="itemDescription">1/4lb grilled hot dog served on a pretzel bun with your choice of cheese sauce or queso. Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-14-lb-chili-dog-combo_06741d77-edb9-4b0a-8acb-680d6e4a49c9" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>1/4 LB Chili Dog Combo</h3></div><div class="priceAvailability"><span class="price">$10.20</span></div><div class="itemContent"><p class="itemDescription">1/4lb Grilled hot dog topped with our homemade chili. Try with cheese and onions! Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-turkey-dressing-sandwich-combo_f985ccab-c4e9-4e39-b440-9fdd7eef4fb8" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Turkey &amp; Dressing Sandwich Combo</h3></div><div class="priceAvailability"><span class="price">$10.00</span></div><div class="itemContent"><p class="itemDescription">This combination of turkey, dressing, and pork sausage is served with your choice of gravy or cranberry sauce on the side. Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-tenderloin-combo_234ccbcd-0228-4d76-8759-cd7df1a7f7ab" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Tenderloin Combo</h3></div><div class="priceAvailability"><span class="price">$11.20</span></div><div class="itemContent"><p class="itemDescription">Delicious pork tenderloin hand-breaded daily and fried to perfection. Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-hot-loin-combo_4296e930-5987-4457-8343-1bfba2e8418c" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Hot Loin Combo</h3></div><div class="priceAvailability"><span class="price">$13.70</span></div><div class="itemContent"><p class="itemDescription">Our hand-breaded pork tenderloin. Served open faced with our homemade mashed potatoes and gravy. Includes fries AND your choice of one side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-tenderloin-tuesday-deal_c71eeeb4-0d09-407d-adf2-c6266cbd922b" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Tenderloin Tuesday Deal</h3></div><div class="priceAvailability"><span class="price">$10.00</span></div><div class="itemContent"><p class="itemDescription">SPECIAL TUESDAY DEAL
Delicious pork tenderloin hand-breaded daily and fried to perfection. Served with fries and a drink!</p></div></div></a></div></section></div><div class="menuGroup"><section class="menuSection"><div class="headerWrapper"><h3 class="header">Entrées</h3></div><div class="itemSection"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-faverite_3bcc6b27-becd-4de7-a1c8-009c2f4d6e07" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/1/item-5740010887569871_1668634390.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/1/item-5740010887569871_1668634390.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/1/item-5740010887569871_1668634390.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/1/item-5740010887569871_1668634390.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/1/item-5740010887569871_1668634390.jpg?size=xs 140w" loading="lazy" alt="Fave-Rite" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>Fave-Rite</h3></div><div class="priceAvailability"><span class="price">$5.35</span></div><div class="itemContent"><p class="itemDescription">Our version of Iowa&#x27;s favorite loose meat sandwich.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-chili-faverite_efcf3587-cb09-47d2-88e5-ad24039c757a" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Chili Fave-Rite</h3></div><div class="priceAvailability"><span class="price">$6.55</span></div><div class="itemContent"><p class="itemDescription">Classic loose meat sandwich served open faced topped with our house made chili.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-hot-rite_25b9c08d-b293-420e-950b-871233e1994e" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Hot Rite</h3></div><div class="priceAvailability"><span class="price">$7.95</span></div><div class="itemContent"><p class="itemDescription">Classic Fave-Rite sandwich served open faced with homemade mashed potatoes and gravy on top.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-tenderloin_e9ff20c0-f47d-43b5-af49-5f91b2e1db85" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019861718510_1668634447.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019861718510_1668634447.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019861718510_1668634447.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019861718510_1668634447.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019861718510_1668634447.jpg?size=xs 140w" loading="lazy" alt="Tenderloin" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>Tenderloin</h3></div><div class="priceAvailability"><span class="price">$6.95</span></div><div class="itemContent"><p class="itemDescription">Delicious pork tenderloin hand-breaded daily and fried to perfection.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-bbq-pork-sandwich_6b2be0c1-d155-48d4-892a-ee19b0ffe09f" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>BBQ Pork Sandwich</h3></div><div class="priceAvailability"><span class="price">$5.95</span></div><div class="itemContent"><p class="itemDescription">Pulled pork in a smoky barbecue sauce.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-14lb-hot-dog_b220cf35-571d-4424-afc9-073bec88a1cc" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>1/4lb Hot Dog</h3></div><div class="priceAvailability"><span class="price">$4.75</span></div><div class="itemContent"><p class="itemDescription">1/4lb grilled hot dog. Try with our house made dill relish!</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-14lb-pretzel-dog_d7a654b1-23f3-4c6a-a147-1c363e5cd225" style="pointer-events:auto" class="item left clickable outOfStock"><div class="itemInfo"><div class="itemHeader"><h3>1/4lb Pretzel Dog</h3></div><div class="priceAvailability"><span class="price">$6.50</span><span>Out of stock</span></div><div class="itemContent"><p class="itemDescription">1/4lb grilled hot dog served on a pretzel bun with your choice of cheese sauce or queso.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-14lb-chili-dog_47472d71-db4d-40df-9890-21afde36a98e" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740011283732823_1668634419.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740011283732823_1668634419.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740011283732823_1668634419.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740011283732823_1668634419.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740011283732823_1668634419.jpg?size=xs 140w" loading="lazy" alt="1/4lb Chili Dog" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>1/4lb Chili Dog</h3></div><div class="priceAvailability"><span class="price">$5.95</span></div><div class="itemContent"><p class="itemDescription">1/4lb Grilled hot dog topped with our homemade chili. Try with cheese and onions!</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-hot-loin_2765f1fd-083f-410a-8c36-e96b6a10c93c" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Hot Loin</h3></div><div class="priceAvailability"><span class="price">$9.45</span></div><div class="itemContent"><p class="itemDescription">Our hand-breaded pork tenderloin. Served open faced with our homemade mashed potatoes and gravy.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-turkey-dressing-sandwich_49d405a4-364f-4f1a-9046-c7ee9ea55810" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740018940472323_1668634471.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740018940472323_1668634471.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740018940472323_1668634471.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740018940472323_1668634471.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740018940472323_1668634471.jpg?size=xs 140w" loading="lazy" alt="Turkey &amp; Dressing Sandwich" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>Turkey &amp; Dressing Sandwich</h3></div><div class="priceAvailability"><span class="price">$5.75</span></div><div class="itemContent"><p class="itemDescription">This combination of turkey, dressing, and pork sausage is served with your choice of gravy or cranberry sauce on the side.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-kids-meal_9b6b69ac-87f6-4ba0-ad03-2c2954a2c585" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Kids Meal</h3></div><div class="priceAvailability"><span class="price">$5.50</span></div></div></a></div></section></div><div class="menuGroup"><section class="menuSection"><div class="headerWrapper"><h3 class="header">Ice Cream</h3></div><div class="itemSection"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-twister_78648aa9-ebf8-4d77-b4c6-b3227b176ae7" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Twister</h3></div><div class="priceAvailability"><span class="price">$4.15<!-- -->+</span></div><div class="itemContent"><p class="itemDescription">Creamy Soft Serve Ice Cream with your choice of candy or sauce mixed in</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-shakemalt_f05a0e7c-56a1-40a8-8878-f67c27d1d6c8" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Shake/Malt</h3></div><div class="priceAvailability"><span class="price">$3.50<!-- -->+</span></div><div class="itemContent"><p class="itemDescription">Vanilla ice cream blended with your choice of sauce.
Chocolate ice cream available at request.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-conecup_9b871f4a-0cc3-4f34-9732-77e46a33159e" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Cone/Cup</h3></div><div class="priceAvailability"><span class="price">$2.25<!-- -->+</span></div><div class="itemContent"><p class="itemDescription">Your choice of a cake cone or dish of our creamy soft serve.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-banana-split_71877d3f-01fd-4a6a-80cf-33b676f38321" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Banana Split</h3></div><div class="priceAvailability"><span class="price">$6.25</span></div><div class="itemContent"><p class="itemDescription">A classic favorite including strawberry, pineapple, Hershey&#x27;s chocolate syrup, whipped cream, and a cherry!</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-sundae_1e1f7ed6-7d6e-4c7d-ae9a-8a86adaae5b2" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Sundae</h3></div><div class="priceAvailability"><span class="price">$3.25<!-- -->+</span></div><div class="itemContent"><p class="itemDescription">A dish of ice cream with your choice of 1-2 toppings</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-chocolate-chip-cookie-sandwich_ccf1e412-7851-423f-96da-08ea8e8ec872" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/5/item-5740010887569895_1668634586.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/5/item-5740010887569895_1668634586.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/5/item-5740010887569895_1668634586.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/5/item-5740010887569895_1668634586.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/5/item-5740010887569895_1668634586.jpg?size=xs 140w" loading="lazy" alt="Chocolate Chip Cookie Sandwich" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>Chocolate Chip Cookie Sandwich</h3></div><div class="priceAvailability"><span class="price">$2.95</span></div><div class="itemContent"><p class="itemDescription">Two fresh baked chocolate chip cookies filled with our creamy soft serve.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-ice-cream-cinnamon-roll_4746c82e-2a9d-4465-a98e-6a8a44522d6f" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Ice Cream Cinnamon Roll</h3></div><div class="priceAvailability"><span class="price">$2.95</span></div><div class="itemContent"><p class="itemDescription">A fresh baked cinnamon roll filled with soft serve and topped with icing.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-float_4030136d-d37a-4fbe-b12b-8dee56fbfc4f" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Float</h3></div><div class="priceAvailability"><span class="price">$3.95</span></div><div class="itemContent"><p class="itemDescription">Classic root beer float served with your choice of Root Beer or Coca Cola.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-willy-nilly-bar_d3232dff-6185-44ac-9e2e-ec4634a4b8ef" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Willy Nilly Bar</h3></div><div class="priceAvailability"><span class="price">$2.00</span></div><div class="itemContent"><p class="itemDescription">Creamy soft serve dipped in chocolate, cherry, butterscotch, or birthday cake coating.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-strawberry-cheesecake-parfait_95d6e558-6632-4562-be2d-1932624f0311" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Strawberry Cheesecake Parfait</h3></div><div class="priceAvailability"><span class="price">$6.50</span></div><div class="itemContent"><p class="itemDescription">Layers of vanilla ice cream, strawberries, and cheesecake bites</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-strawberry-shortcake-parfait_03eba43a-3769-432f-bd9b-eb75be48a2be" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Strawberry Shortcake Parfait</h3></div><div class="priceAvailability"><span class="price">$6.50</span></div><div class="itemContent"><p class="itemDescription">Layers of vanilla ice cream, strawberries, and shortcake</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-caramel-apple-crisp-parfait_7ae7c571-89bb-4d3b-a84a-bc18f1b1cfef" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Caramel Apple Crisp Parfait</h3></div><div class="priceAvailability"><span class="price">$6.50</span></div><div class="itemContent"><p class="itemDescription">Layers of vanilla ice cream, cinnamon apples, homemade crumb topping and caramel.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-brookie-bliss-parfait_82eeeb38-cb0f-46c3-8737-8cf99b37fcbc" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740016360386693_1668634562.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740016360386693_1668634562.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740016360386693_1668634562.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740016360386693_1668634562.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/3/item-5740016360386693_1668634562.jpg?size=xs 140w" loading="lazy" alt="Brookie Bliss Parfait" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>Brookie Bliss Parfait</h3></div><div class="priceAvailability"><span class="price">$6.50</span></div><div class="itemContent"><p class="itemDescription">Layers of vanilla ice cream, hot fudge, brownie bites, and chocolate chip cookie dough.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-smores-supreme-parfait_a38378b1-6a8a-40ad-b303-3ca391ab6bd0" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>S&#x27;mores Supreme Parfait</h3></div><div class="priceAvailability"><span class="price">$6.50</span></div><div class="itemContent"><p class="itemDescription">Layers of vanilla ice cream, mini chocolate chips, Hershey&#x27;s chocolate syrup, marshmallow cream, graham crackers, and mini marshmallows.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-tasty-turtle-parfait_2325e35a-95dd-4005-af0d-1e4c42694330" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Tasty Turtle Parfait</h3></div><div class="priceAvailability"><span class="price">$6.50</span></div><div class="itemContent"><p class="itemDescription">Layers of vanilla ice cream, hot fudge, caramel, and pecans.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-pup-cup_5bb78549-5690-4af4-80c7-ef5194fa837b" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Pup Cup</h3></div><div class="priceAvailability"><span class="price">$1.00</span></div><div class="itemContent"><p class="itemDescription">Vanilla ice cream topped with a dog treat for your pups!</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-ice-cream-pint_989c3d42-d38d-4a61-b58c-a55af9bf7e11" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Ice Cream PINT</h3></div><div class="priceAvailability"><span class="price">$4.00</span></div><div class="itemContent"><p class="itemDescription">A pint of our creamy soft serve with your choice of mix in toppings</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-ice-cream-quart_fec8e423-8fee-45e9-b6b6-a552d55e0631" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Ice Cream QUART</h3></div><div class="priceAvailability"><span class="price">$6.50</span></div><div class="itemContent"><p class="itemDescription">A quart of our creamy soft serve with your choice of mix in toppings</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-grab-bag_97efb8b9-9215-4c6a-a3e5-a6173833d32f" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Grab Bag</h3></div><div class="priceAvailability"><span class="price">$15.00</span></div><div class="itemContent"><p class="itemDescription">A mystery assortment of our various ice cream treats.</p></div></div></a></div></section></div><div class="menuGroup"><section class="menuSection"><div class="headerWrapper"><h3 class="header">Sides &amp; Soups</h3></div><div class="itemSection"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-side-dish_e8730c97-effa-4645-9b32-111628a24968" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Side Dish</h3></div><div class="priceAvailability"><span class="price">$2.00<!-- -->+</span></div><div class="itemContent"><p class="itemDescription">Choose from our wide variety of side dishes a la carte.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-chili_c485ee0f-72f6-4339-afc3-9060a546519b" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Chili</h3></div><div class="priceAvailability"><span class="price">$3.95<!-- -->+</span></div><div class="itemContent"><p class="itemDescription">An old family recipe of delicious chili.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-daily-soup_4d8060b9-ff13-4bd8-9c88-4978b83315bf" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Daily Soup</h3></div><div class="priceAvailability"><span class="price">$3.95<!-- -->+</span></div><div class="itemContent"><p class="itemDescription">A variety of homemade soups changes daily. Check Facebook or call us to find out the daily soup.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-white-cheddar-cheese-curds_5b2c2b07-3020-4267-af33-bf6fd4f1cc58" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019891710850_1668634319.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019891710850_1668634319.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019891710850_1668634319.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019891710850_1668634319.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/0/item-5740019891710850_1668634319.jpg?size=xs 140w" loading="lazy" alt="White Cheddar Cheese Curds" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>White Cheddar Cheese Curds</h3></div><div class="priceAvailability"><span class="price">$5.95</span></div><div class="itemContent"><p class="itemDescription">Delicious white cheddar cheese curds breaded and fried. Served with a side of ranch</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-regular-fries_d92aef16-d8ac-4554-bf58-cf1934146a42" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Regular Fries</h3></div><div class="priceAvailability"><span class="price">$2.75</span></div><div class="itemContent"><p class="itemDescription">A basket of our lightly seasoned fries.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-cheese-fries_29411cec-7b14-43f5-98df-95f2cb679de0" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Cheese Fries</h3></div><div class="priceAvailability"><span class="price">$4.25</span></div><div class="itemContent"><p class="itemDescription">A basket of our lightly seasoned fries topped with a three cheese blend and served with a side of ranch.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-bacon-cheese-fries_6113aec9-03ec-4706-a78d-cbe7eee8385e" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Bacon Cheese Fries</h3></div><div class="priceAvailability"><span class="price">$6.95</span></div><div class="itemContent"><p class="itemDescription">A basket of our lightly seasoned fries topped with a three cheese blend and bacon. Served with a side of ranch.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-chili-cheese-fries_edd6df04-4ce3-4997-84a9-10a0112ed478" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Chili Cheese Fries</h3></div><div class="priceAvailability"><span class="price">$6.95</span></div><div class="itemContent"><p class="itemDescription">Our lightly seasoned fries topped with homemade chili, three cheese blend, and a side of sour cream.</p></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-nacho-fries_daaeeef0-441a-4013-9f90-fdf90b48e7d0" style="pointer-events:auto" class="item left clickable"><img src="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/8/item-5740021031771868_1668634354.jpg?size=medium" srcSet="https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/8/item-5740021031771868_1668634354.jpg?size=large 900w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/8/item-5740021031771868_1668634354.jpg?size=medium 600w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/8/item-5740021031771868_1668634354.jpg?size=small 300w, https://d2s742iet3d3t1.cloudfront.net/restaurants/restaurant-76524000000000000/menu/items/8/item-5740021031771868_1668634354.jpg?size=xs 140w" loading="lazy" alt="Nacho Fries" class="itemImage vertical"/><div class="itemInfo"><div class="itemHeader"><h3>Nacho Fries</h3></div><div class="priceAvailability"><span class="price">$7.95</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-side-of-ranch_2625fc54-653e-4f78-a713-8747d303ee2c" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Side of Ranch</h3></div><div class="priceAvailability"><span class="price">$0.50</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-side-of-sour-cream_15118bd0-17d4-4fd0-944d-15742bfd1c25" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Side of Sour Cream</h3></div><div class="priceAvailability"><span class="price">$0.50</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-side-of-gravy_c02d5374-50d0-4d40-b1df-334b2c6d0030" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Side Of Gravy</h3></div><div class="priceAvailability"><span class="price">$0.50</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-pint-turkey-dressing_e8dcc018-58f0-4d0c-8361-46f9fc80026f" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>PINT Turkey &amp; Dressing</h3></div><div class="priceAvailability"><span class="price">$12.00</span></div></div></a></div></section></div><div class="menuGroup"><section class="menuSection"><div class="headerWrapper"><h3 class="header">Drinks</h3></div><div class="itemSection compact"><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-kids-soda_e59b5b64-e270-4d43-8bdb-856ec33ca1ea" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Kids Soda</h3></div><div class="priceAvailability"><span class="price">$1.00</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-soda_a28e7c07-dacd-4db8-9386-c6ee159c0310" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Soda</h3></div><div class="priceAvailability"><span class="price">$2.00</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-iced-tea_088d4c05-36b3-4bb1-84f3-56db952abd8e" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Iced Tea</h3></div><div class="priceAvailability"><span class="price">$2.00</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-lemonade_2957e891-8b50-493b-95fd-621c4fd1d12b" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Lemonade</h3></div><div class="priceAvailability"><span class="price">$2.00</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-coffee_0ce52e31-c51e-4924-a8ef-d013c046de5e" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Coffee</h3></div><div class="priceAvailability"><span class="price">$1.50</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-hot-chocolate_50a749a6-b86e-4a42-8e83-e0199d30f335" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Hot Chocolate</h3></div><div class="priceAvailability"><span class="price">$2.00</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-slushie_b5602478-75e9-4a89-b65d-b4c108568bfa" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Slushie</h3></div><div class="priceAvailability"><span class="price">$2.00<!-- -->+</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-slushie-float_a653b64b-d7f4-4638-bc67-6ee2b891b580" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Slushie Float</h3></div><div class="priceAvailability"><span class="price">$3.95</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-slushy-twist_2c982136-c818-40ad-a792-0960cc971e5b" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Slushy Twist</h3></div><div class="priceAvailability"><span class="price">$3.95</span></div></div></a><a href="/local/order/barkers/r-20e59555-7498-4f16-aa82-98a1b72b3128/item-water_96c23f81-5e5d-4a9c-9b10-dfc31bb2daeb" style="pointer-events:auto" class="item left clickable"><div class="itemInfo"><div class="itemHeader"><h3>Water</h3></div><div class="priceAvailability"><span class="price"></span></div></div></a></div></section></div></div></div></div></div><div class="paddedSection rxPageSectionWrapper"><div><hr class="divider"/></div><div class="rx-page-section rx-cards"><div class="rx-hours" id="hours"><div class="title-card open"><div class="title txt-body-lg">All hours</div><div class="children"><div class="hours-container" id="rx-hours"><table><tbody><tr class=""><td>Sunday</td><td class="hours">Closed</td></tr><tr class=""><td>Monday</td><td class="hours">4:00 am - 3:59 am</td></tr><tr class=""><td>Tuesday</td><td class="hours">4:00 am - 3:59 am</td></tr><tr class=""><td>Wednesday</td><td class="hours">4:00 am - 3:59 am</td></tr><tr class=""><td>Thursday</td><td class="hours">4:00 am - 3:59 am</td></tr><tr class="bold"><td>Friday</td><td class="hours">4:00 am - 3:59 am</td></tr><tr class=""><td>Saturday</td><td class="hours">4:00 am - 3:59 am</td></tr></tbody></table></div></div></div></div><div class="rx-description"><div class="title-card open"><div class="title txt-body-lg">Restaurant info</div><div class="children"><p>Local shop serving soft serve ice cream treats and hot food year round.</p></div></div></div><div class="location"><div class="title-card open"><div class="title txt-body-lg">Location</div><div class="children"><div class="location-container"><p>2100 7TH AVE, Marion, IA 52302</p><p><a href="https://www.google.com/maps/dir/?api=1&amp;destination=Barker&#x27;s%20Ice%20Cream%20%26%20More%2C%202100%207TH%20AVE%2C%20Marion%2C%20IA%2052302}" target="_blank" rel="noreferrer noopener">Directions</a></p><img height="300" loading="lazy" src="https://maps.googleapis.com/maps/api/staticmap?key=AIzaSyDsJlw0WSpry4Kig6-1LfjR0vo89NYZudM&amp;style=feature:poi|visibility:off&amp;markers=color:0xFF4C00%7CBarker&#x27;s%20Ice%20Cream%20%26%20More%2C%202100%207TH%20AVE%2C%20Marion%2C%20IA%2052302&amp;zoom=14&amp;size=640x300" class="location-img"/></div></div></div></div></div></div><div class="paddedSection rxPageSectionWrapper"><div><hr class="divider"/></div><div class="rx-page-section rx-gallery" id="rx-gallery"><div class="title-card open"><div class="title txt-body-lg">Gallery</div><div class="children"><div class="gallery-container"><div class="tabs"><button class="tab selected" tabindex="0" role="button" aria-pressed="true">All Photos</button><button class="tab " tabindex="0" role="button" aria-pressed="false">Menu</button><button class="tab " tabindex="0" role="button" aria-pressed="false">Restaurant</button></div><div class="photos"><div class="photo first rounded-border"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-consumer-154609-281.webp" srcSet="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-consumer-154609-350.webp 350w, https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-consumer-154609-281.webp 281w" loading="lazy" alt="BARKER&#x27;S ICE CREAM AND MORE image"/></div><div class="rest"> <div class="photo rounded-border"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-banner-154608-740.webp" srcSet="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-banner-154608-1047.webp 1047w, https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-banner-154608-740.webp 740w, https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-banner-154608-331.webp 331w" loading="lazy" alt="BARKER&#x27;S ICE CREAM AND MORE image"/></div></div><div class="rest"> <div class="photo rounded-border"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-main-154607-2610.webp" srcSet="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-main-154607-3691.webp 3691w, https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-main-154607-2610.webp 2610w, https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/20e59555-7498-4f16-aa82-98a1b72b3128/barkers-ice-cream-and-more-main-154607-1167.webp 1167w" loading="lazy" alt="BARKER&#x27;S ICE CREAM AND MORE image"/></div></div></div></div></div></div></div><div><hr class="divider"/></div></div><div class="paddedSection rxPageSectionWrapper"><div class="rx-carousel rx-page-section"><div class="title-section"><h2>Similar restaurants in your area</h2><div class="scroll-button-section hidden-sm-down"><button class="arrow"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/chevron-left-gray.svg" loading="lazy" alt="scroll left"/></button><button class="arrow"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/chevron-right-gray-24.svg" loading="lazy" alt="scroll right"/></button></div></div><div class="element-grid"><div class="pure-g restaurants"><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/big-shots-1803-6th-ave/r-48603dc3-4f1e-428f-8153-36d6580abef0"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/48603dc3-4f1e-428f-8153-36d6580abef0/big-shots-bar-and-grill-consumer-129477-295.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">Big Shots Bar and Grill - 1803 6th Ave</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>4.2 • 139</div></div><div class="address-line">1803 6th Ave Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/frydae-743-10th-st/r-65fe7ea1-4fe8-4aea-9d04-df3cda1f1663"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/65fe7ea1-4fe8-4aea-9d04-df3cda1f1663/frydae-consumer-159641-350.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">Frydae - 743 10th St</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>No Reviews</div></div><div class="address-line">743 10th St Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/west-end-diner/r-8fca7483-8dd8-4475-8255-d89fd2edcf91"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/8fca7483-8dd8-4475-8255-d89fd2edcf91/west-end-diner-consumer-140293-580.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">West End Diner</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>4.7 • 123</div></div><div class="address-line">809 6th Avenue Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/goldfinch-tap-eatery/r-46a7c1ba-cd00-40e2-99d5-667a0d4e6357"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/46a7c1ba-cd00-40e2-99d5-667a0d4e6357/goldfinch-tap--eatery-main-150395-495.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">Goldfinch Tap + Eatery</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>4.4 • 431</div></div><div class="address-line">740 10th Street Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/earl-s-chill-and-grill-955-29th-ave-suite-a/r-5bf5cd3d-ba23-4581-9c4a-09bba994a8fa"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/5bf5cd3d-ba23-4581-9c4a-09bba994a8fa/earls-chill-and-grill-consumer-51799032-784.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">Earl&#x27;s Chill and Grill</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>No Reviews</div></div><div class="address-line">955 29th Ave Suite A Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/nara-thai-cuisine-1725-blairs-ferry-road/r-bccba555-aa02-4d07-a78a-ea942d760496"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/bccba555-aa02-4d07-a78a-ea942d760496/nara-thai-cuisine-consumer-214842-350.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">Nara Thai Cuisine</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>No Reviews</div></div><div class="address-line">1725 Blairs Ferry Road Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div></div></div><div class="more-rx-button hidden-sm-down"></div></div></div><div class="paddedSection rxPageSectionWrapper"><div class="rx-carousel rx-page-section"><div class="title-section"><h2>Popular restaurants in Marion</h2><div class="scroll-button-section hidden-sm-down"><button class="arrow"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/chevron-left-gray.svg" loading="lazy" alt="scroll left"/></button><button class="arrow"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/chevron-right-gray-24.svg" loading="lazy" alt="scroll right"/></button></div></div><div class="element-grid"><div class="pure-g restaurants"><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/goldfinch-tap-eatery/r-46a7c1ba-cd00-40e2-99d5-667a0d4e6357"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/46a7c1ba-cd00-40e2-99d5-667a0d4e6357/goldfinch-tap--eatery-main-150395-495.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">Goldfinch Tap + Eatery</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>4.4 • 431</div></div><div class="address-line">740 10th Street Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/big-shots-1803-6th-ave/r-48603dc3-4f1e-428f-8153-36d6580abef0"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/48603dc3-4f1e-428f-8153-36d6580abef0/big-shots-bar-and-grill-consumer-129477-295.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">Big Shots Bar and Grill - 1803 6th Ave</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>4.2 • 139</div></div><div class="address-line">1803 6th Ave Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div><div class="carousel-listing pure-u-12-24 pure-u-md-8-24 pure-u-lg-6-24"><a class="" href="/local/order/west-end-diner/r-8fca7483-8dd8-4475-8255-d89fd2edcf91"><div class="listing-image-container"><img src="https://toast-local-nyc3-production.nyc3.cdn.digitaloceanspaces.com/restaurants/8fca7483-8dd8-4475-8255-d89fd2edcf91/west-end-diner-consumer-140293-580.webp" loading="lazy" class="listing-image"/></div><div class="listing-content"><div class="first-line"><span class="rx-name">West End Diner</span><div class="review-summary"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-solid-orange.svg" loading="lazy" alt="orange star"/>4.7 • 123</div></div><div class="address-line">809 6th Avenue Marion, IA 52302</div><div class="view-rx">View restaurant<img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/arrow-right-gray.svg" loading="lazy" alt="next" height="18" class="icon-img"/></div></div></a></div></div></div><div class="more-rx-button hidden-sm-down"><a href="/local/marion-ia-restaurants" target="_blank" rel="noreferrer" class="btn"><div class="btn-text">Search popular restaurants</div></a></div></div></div><div class="paddedSection rxPageSectionWrapper"><div class="rx-hot-spots"><div class="title-section"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/map-with-path.svg" loading="lazy" alt="Map" height="42" class="icon"/><div class="title txt-body-xxl">More near Marion</div></div><div class="element-grid"><div class="pure-g hot-spots"><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/cedar-rapids-ia-restaurants" class=""><div class="txt-body-xl">Cedar Rapids</div></a><div class="avg-rating" title="This restaurant has a 4.5 rating from 25 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.5<!-- --> <span class="text-color-gray">(<!-- -->25<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/north-liberty-ia-restaurants" class=""><div class="txt-body-xl">North Liberty</div></a><div class="avg-rating" title="This restaurant has a 4.4 rating from 6 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.4<!-- --> <span class="text-color-gray">(<!-- -->6<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/coralville-ia-restaurants" class=""><div class="txt-body-xl">Coralville</div></a><div class="avg-rating" title="This restaurant has a 4.3 rating from 14 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.3<!-- --> <span class="text-color-gray">(<!-- -->14<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/iowa-city-ia-restaurants" class=""><div class="txt-body-xl">Iowa City</div></a><div class="avg-rating" title="This restaurant has a 4.5 rating from 44 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.5<!-- --> <span class="text-color-gray">(<!-- -->44<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/waterloo-ia-restaurants" class=""><div class="txt-body-xl">Waterloo</div></a><div class="avg-rating" title="This restaurant has a 4.7 rating from 9 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.7<!-- --> <span class="text-color-gray">(<!-- -->9<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/dubuque-ia-restaurants" class=""><div class="txt-body-xl">Dubuque</div></a><div class="avg-rating" title="This restaurant has a 4.5 rating from 18 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.5<!-- --> <span class="text-color-gray">(<!-- -->18<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/davenport-ia-restaurants" class=""><div class="txt-body-xl">Davenport</div></a><div class="avg-rating" title="This restaurant has a 4.1 rating from 16 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.1<!-- --> <span class="text-color-gray">(<!-- -->16<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/bettendorf-ia-restaurants" class=""><div class="txt-body-xl">Bettendorf</div></a><div class="avg-rating" title="This restaurant has a 4.4 rating from 8 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.4<!-- --> <span class="text-color-gray">(<!-- -->8<!-- --> restaurants<!-- -->)</span></div></div></div></div><div class="simple-listing pure-u-12-24 pure-u-md-8-24"><div class="listing-content"><a href="https://www.toasttab.com/local/clinton-ia-restaurants" class=""><div class="txt-body-xl">Clinton</div></a><div class="avg-rating" title="This restaurant has a 4.3 rating from 1 reviews on restaurant review sites."><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/star-full-blue.svg" loading="lazy" alt="review star"/><div class="txt-body-sm">Avg <!-- -->4.3<!-- --> <span class="text-color-gray">(<!-- -->1<!-- --> restaurants<!-- -->)</span></div></div></div></div></div></div></div></div><div class="footer"><div class="footer-container generic-container"><div class="footer-content"><div class="content-cell pure-g"><div class="footer-nav pure-u-12-24 pure-u-sm-6-24"><div>© <!-- -->2022<!-- --> Toast, Inc.</div><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/toast-logo.svg" loading="lazy" alt="Toast" height="45" class="toast-badge"/></div><ul class="footer-nav nav-down pure-u-12-24 pure-u-sm-6-24"><li><a href="https://pos.toasttab.com/about" class="" target="_blank" rel="noopener noreferrer">About Toast</a></li><li><a href="https://pos.toasttab.com/" class="" target="_blank" rel="noopener noreferrer">For restaurants</a></li></ul><ul class="footer-nav nav-down pure-u-12-24 pure-u-sm-6-24"><li><a href="https://pos.toasttab.com/terms-of-service" rel="noopener noreferrer" class="" target="_blank">Terms of Service</a></li><li><a href="https://pos.toasttab.com/privacy" rel="noopener noreferrer" class="" target="_blank">Privacy Statement</a></li><li><a href="https://pos.toasttab.com/privacy#addendum" rel="noopener noreferrer" class="" target="_blank">Do not sell my<br/>personal information</a></li></ul><div class="footer-nav nav-down pure-u-12-24 pure-u-sm-6-24">Made with <img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/heart-orange.svg" loading="lazy" alt="love" height="11" class="heart-icon"/> in Boston<ul class="footer-nav social-media"><li><a href="https://instagram.com/toasttab" target="_blank" rel="noreferrer"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/instagram-gray.svg" loading="lazy" alt="Instagram" class="instagram" height="12"/></a></li><li><a href="https://twitter.com/toasttab" target="_blank" rel="noreferrer"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/twitter-gray.svg" loading="lazy" alt="Twitter" class="twitter" height="12"/></a></li><li><a href="https://www.facebook.com/toasttab/" target="_blank" rel="noreferrer"><img src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/icons/facebook-gray.svg" loading="lazy" alt="Facebook" class="facebook" height="12"/></a></li></ul></div></div></div></div></div></div></div></div>
    <script nonce="a18196195bf3ffa404809d6c2a3b2f11">(function(){var s=document.createElement("script");s.nonce="a18196195bf3ffa404809d6c2a3b2f11";s.type="text/javascript";s.async=true;s.src="https://toast-sites-prod.nyc3.cdn.digitaloceanspaces.com/app/public_1669921619.min.js";var x=document.getElementsByTagName("script")[0];x.parentNode.insertBefore(s,x);})();</script>
  <script>(function(){var js = "window['__CF$cv$params']={r:'7730dbf3694a81eb',m:'jw5Di9o0_amvBOaVd3dKz_I1EkMA8mEYO26TA8zF8FY-1669950519-0-AXb+9XrUzxz6PlYbU1ok/CDRCUUD915qRhrkXmCSJqR8lylgj33fIXFwEyap0DiHDC1ou4KwCv8WBOmP1z9QxJuEBjjOspynYmsdw53fXDpmmgEFHasf+gV/NEKV/VFye2DgYMo6KM1AdOZsk32oPwOr0Y1oo+qgGWikcelLSsr59iysc2bLleDxyusQa3MAEg==',s:[0x935ba3cbde,0xaf4653c580],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>